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RhizoVision Explorer 

Root image analysis for the rest of us 

 

RhizoVision Explorer is free and open-source software developed for estimating root traits from 

images acquired from a flatbed scanner or camera. Root images are expected to have a high 

contrast of roots with the background, homogenous lighting, and minimal overlapping of roots. 

The software is built in C++ for speed and stability, using QT for the graphical user interface and 

OpenCV for image processing. Traits extracted by RhizoVision Explorer have been extensively 

validated using a physical copper wire ground truth image set, thousands of simulated roots, and 

comparisons with other image analysis software. The default “Broken Roots” mode is meant for 

roots washed out from soil cores or pots that are disconnected and provides length, volume, 

branching frequency, among other features, with the ability to bin measurements based on 

diameter thresholds. The “Whole Root” mode extracts additional root system architecture 

features of more intact root systems, especially excavated root crowns or rhizoboxes, such as the 

convex hull, angles, and holes. The software supports multiple regions of interest, batch mode, 

and user-defined export of processed images with overlaid features for use in reports.  

Minimum requirements are Windows 10 or 8 operating system, an Intel or AMD x86_64 

processor, and 8 GB of RAM. If the processor supports Intel AVX 2.0, the code is optimized. 

You can redistribute it and/or modify it as permissible under the GNU General Public License. 

The source code is available on GitHub.  

Please contact the creators with concerns or comments 
Larry M. York 

larry.york@gmail.com 

 

Anand Seethepalli  

anand_seethepalli@yahoo.co.in 

 

Citing the software – We humbly ask you cite the software when reporting data it generated in 

presentations or manuscripts. 

Software: Seethepalli A and York LM. RhizoVision Explorer - Interactive software for generalized root 
image analysis designed for everyone (Version 2.0.3). Zenodo.  DOI: 10.5281/zenodo.3747697  
 
Manuscript: Seethepalli A, Dhakal K, Griffiths M, Guo H, Freschet GT, York LM (2021). RhizoVision 
Explorer: Open-source software for root image analysis and measurement standardization.   
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Load software – Simply double click RhizoVisionExplorer.exe 

 

Hot tip! Right-click on RhizoVisionExplorer.exe and choose “Pin to taskbar” for quick access 

Overview 

 

RhizoVision Explorer is divided into groups of panes, as shown above. The histogram pane only appears 

after feature extraction. The overall workflow is: 

1. Load image by drag-and-drop to the Image pane or selecting an image from the File menu. 

2. Use the Analysis Options pane for pre-processing, feature extraction, and output settings. 

3. Use the Image pre-processing area to choose whether a whole root (like a root crown) or broken 

roots (usually scanned), supply image resolution in either DPI or pixels per mm, set the pixel intensity 

level for identifying roots, and filter out objects by relatively small sizes such as dirt. 

4. Use the Feature extraction area to enable root pruning to erase short, erroneous root segments from 

the output and set diameter ranges. Use interactively to optimize the settings. 

5. Use the Output display area to change which image features are displayed on the feature image. 

6. Use Run analysis on the Toolbar to process the image, output the display image and numeric 

features. 

7. This workflow may be repeated for images within a folder or continued with batch mode (see below). 

 
Hot tip!  RhizoVision Explorer converts pixel values (default) to mm, mm2, and mm3 for length, area, and volume, respectively, 

when the image resolution is supplied in the Image pre-processing options
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The main Toolbar, as shown below, groups various ways to interact with the root image data. 

 

Loading an image 
a. Single image (useful for testing or small image sets with different regions of interest  

i. Drag and drop image into gray image pane window 

 
ii. File > Open 

 
 

b. Batch mode (when you know your image settings and/or fixed ROI regions) 

i. File > Batch analysis 
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Choose appropriate root image pre-processing settings 
Change a setting (see below) > press Preview segmented image > Compare Display output tab 

RhizoVision Explorer expects black roots on a white background. If you have white roots on a black 

background, choose the Invert image option in the Toolbar first, then continue. 

The Analysis Options pane contains tools for Image pre-processing 

(segmenting) the image, Feature extraction (pruning and diameter 

bins), and what features to overlay in Output display. These 

settings should be adjusted interactively until you are satisfied. 

 

Analysis mode determines defaults for filtering objects and 

providing extra architectural data as described on the next page. 

 

Convert pixels to physical units accepts DPI for scanners or pixels 

per mm as measured by the user for a camera system. 

 

Image thresholding level should be adjusted to maximize clean 

root borders while limiting the appearance of noise. 

   

Filter non-root objects removes black specs like dirt that are not root. Objects smaller than set size are 

erased. Fill holes works oppositely, to fill in holes (white spaces) on the roots, but is rarely needed. 

   

Enable edge smoothing smooths root edges to decrease false roots during skeletonization. Higher values 

smooth more. In general, using Pruning in Feature extraction is preferred due to distortion. 
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Broken roots analysis is the default because the method is common, typically for washed-out roots from 

pots or soil cores where the underlying architecture is lost and the root system is disconnected. 

 

Example of a Whole root analysis and options using a root crown from the RhizoVision Crown platform 

 

Example of Whole root analysis and options for a rhizobox image where roots may still be disconnected 

but where angles, convex hull, system width, and depth are still relevant.  
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Feature extraction settings 
Change a setting (see below) > press Run analysis button to test > Compare Display output tab 

 
Root pruning is recommended to delete false root segments 

where tips are longer than the diameter of the parent root plus 

the additional pixels supplied in the Root pruning threshold. 

Values between 1-20 are recommended to reduce unwanted 

tips. Higher values reduce false tips, but can reduce total length. 

 

Diameter ranges can be set to capture fine roots below 2 mm or 

separate lateral roots from their parents through interactive 

adustment. Up to 10 ranges are currently supported. 

 

 

The raw skeleton on the left has many short root segments that lead to the overestimation of root 

parameters. By enabling pruning, segments longer than the diameter of their parent are deleted (right). 

 

      
Hot tip!  In the Output display setting, turn off Color media axis by diameter and set Medial axis width to 1 to display 

topological points like tips in green, branch points in blue, and segments in red. 

The heterogeneity of root diameters within a sample can vary greatly and is determined mainly by the 

number of root orders or lateral branching. In many cases, the length of lateral roots and their parent 

roots can be quantified separated by appropriate adjustment of these diameter ranges. Ranges can be 

added to a maximum of 10 or deleted to a minimum of 1 (left), but in this case 2 was optimal (right). 
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Features and Log pane 

The Features tab is displayed after Run analysis completes all operations, with the most recent analysis 

appearing as the last row of the output. The first column gives the file name, and the second the “Region 

of Interest” (ROI) which will list “Full” if it was the whole image, or else will use either default ROI names 

or the names provide in the ROI manager (see below). Every feature is given in the column headers, along 

with the correct units. When features are saved (see below), these names are converted to formats 

without spaces or exponents for loading directly into common data analysis pipelines, such as R or Python. 

Missing values are stored as ‘NA’. One or multiple rows can be selected to clear those or all rows by right-

clicking. 

 

 

The Log tab is displayed to show major events or warnings. The Features tab will activate if another 

analysis is executed. 

 

 

Region of interest tool 

 
Use the ROI tool to draw new regions of interest (ROI) or to move and resize ROIs. 
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ROIs are displayed as red rectangles. An active ROI is displayed with a dashed rectangle if it has just been 

drawn, has been selected with the ROI tool, or has been selected in the ROI List within the ROI Manager 

pane. The ROI tool allows the active ROI to be resized, moved, or deleted with the ‘delete’ key. The ROI 

Manager allows an ROI to be renamed, manually updating coordinates and size, and selecting an ROI from 

a list. All ROIs can be cleared from the Edit menu. 

Example 1. Use the ROI tool to crop out the tray in flatbed scanner images 

       

Example 2. Create multiple ROIs, each with a different name, to separate samples in the same image. As 

shown in the Features section, a second column after File Names displays the named ROIs, which allows 

convenient subsequent data import and analysis. 

   
 

Once a single or multiple ROIs are drawn, they may be saved for reuse using the File > Save as > 

Annotations, and loaded using File > Open > Load annotation 

 
Hot tip!  The ROIs drawn on an interactive image are honored for the next loaded image, and also in batch analysis. Therefore, 

samples should be placed consistently during imaging or scanning for ease of subsequent image analysis.  



RhizoVision Explorer Manual - Page 10 
 

Save features data and batch analysis 
Interactive data analysis is possible in RhizoVision Explorer by using the load previous and next arrows to 

move through a directory of images and manually clicking on Run analysis for each image. The trait 

features will be stored in the Features pane, and can be saved using Menu > Save as > Features. 

However, the real strength of this software is using the interactive mode for optimize settings and then 

using Batch Analysis as described next. 

Batch Analysis is found by using the menu File > Batch Analysis 

Settings are inherited from the pre-processing, feature extraction, and output display 

Choose image folder location – defaults to last 

loaded image directory 

 

Choose output location – Browse defaults to Image 

location – recommended to create an Output folder 

to use 

 

Update file names for the features CSV file 

containing the data and the metadata CSV file, 

which contains all the settings used for the run. The 

Metadata file is the same as a Settings file, so can 

be loaded later, or shared for reproducibility. 

 

Optionally choose to output either segmented or 

processed images, and choose a suffix to append to 

the file name. Images are saved as PNG. 

 

Press Start! 

 

 

Current file shows the file being processed, Time 

elapsed shows the actual time elapsed since start, 

and Est. time remaining uses the average 

processing time and number of remaining files to 

estimate. The progress bar shows the percentage of 

finished images. 

 

Stop or Pause can be used to restart analysis. Quit 

exits without finishing. 

 

The log shows Processing then Process complete 

once progress reaches 100%. 
 

Hot tip!  You can view the Output directory to see the saved images being populated. However, do not open the features CSV file 

until batch processing is complete because data will not be stored correctly.  
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Display output settings 
 

 

 

One unique strength of this software is giving users more ability to choose output images that display 

features on top of the segmented images. Output display allows choosing the options and a few settings. 

Show convex hull and Show holes are only available for Whole root analysis mode. 

Show distance map will show a green mist within the segmented root with the intensity defined by the 

distance of a pixel from the edge, more intensive in the center of the root. This distance map is what was 

used to identify the ridges in order to create the root skeleton. 

Show medial axis shows the root skeleton. 

Hot tip! Set the Medial axis width to higher values to artificially thicken the skeleton, or even beyond the original root size to 

make roots more visible for presentations or posters, as shown above. 

Color medial axis based on diameter ranges uses color-blind friendly colors to represent skeleton pixels 

falling within the user-set diameter ranges. 

Hot tip!  Turn off Color medial axis based on diameter ranges to view the root topology points as described for root pruning 

above. Changing Medial axis width to 1 will give the user a very good idea of the skeleton topology.  

Show root contour displays the boundary of the roots or perimeter in red color, and the width can be 

chosen.  
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Using features CSV file with external software like Excel and R 

The features CSV files are standard comma separated values text files (*.csv), and characters are encoded 

in UTF-8 to support multiple languages. When using Latin alpha-numeric characters, generally, the files 

can be used without special consideration by programs like Excel and R. However, if your original image 

file names had non-Latin characters, please refer to the following instructions to display these correctly. 

Excel 

If you open the file in Excel, you may notice non-Latin characters are not rendered correctly, because Excel 

may not recognize the correct encoding. You can use the text import feature by going to the Data tab, in 

the Get External Data area, and choose From Text to start the import wizard  

 

 

Choose delimited, import row 1, and file origin as Unicode (UTF-8), and with headers, the click next 

 

Choose comma as the delimiter and click Finish 
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Choose New worksheet, then OK to display the file correctly 

 

R and RStudio 

The features CSV file exported by RhizoVision Explorer was designed for direct use in R or Python. 

The new versions of R and RStudio support importing files with UTF-8 encoding in multiple languages. 

Older versions do not. We recommend using at least R version 4 and RStudio version 1.3 

If only Latin alpha-numeric characters were used, generally the default read.csv function will work. 

If additional characters were used, simply specify UTF-8 encoding as in the following example: 

features_german <- read.csv("C:/ Fußgänger/FußgängerOut/features.csv", encoding="UTF-8") 
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List of extracted features and their definitions  
 

The list of features extracted from each root crown image by RhizoVision Explorer. Pixels are converted 
to physical units using the user-supplied conversion factors. Length, surface area, and volume are 
additionally computed within user-supplied diameter ranges. Features exclusive to Whole root mode 
are highlighted in red and Broken roots mode in blue. 

Features extracted Description 

Median and maximum 

number of roots 

The number of roots is counted by performing horizontal line scans 

from left to right in each row through the segmented image. In each of 

the line scan, we check if there is a pixel value transition from the 

previous pixel value to the current pixel value on its right side. If the 

current pixel value changes from 0 to 1, we note that a root is present. 

The number of roots is recorded from each row of the segmented 

image, and the median and the maximum number of roots is determined 

from these values. 

Number of Root Tips Computed by counting the total number of tip pixels in the skeletonized 

image with topology  

Total root length Computed by counting the total number of pixels in the skeletonized 

image. Diagonal pixels are counted as the sqrt(2) 

Perimeter Perimeter is the count of the total number of pixels in the perimeter 

image. 

Average, median, and 

maximum diameter 

For each pixel on the skeletonized image, the distance to the nearest 

non-root pixel is computed and using this distance as radius a circle is 

fitted. The diameter of the circle at each pixel is noted as the diameter 

at that pixel. We get the list of diameters from all the medial axis pixels 

and determine the average, median, and maximum diameter. 

Volume and surface 

area 

Using the radii determined earlier, the sum of all cross-sectional areas 

across all the medial axis pixels are noted as volume and the sum of the 

perimeter across all the medial axis pixels are noted as surface area. 

Network area The network area is the total number of pixels in the segmented image. 

Branch points Computed by counting the total number of branch pixels in the 

skeletonized image with topology  

Branching frequency  The number of branch points divided by the total root length 

Depth, maximum width 

and width-to-depth 

ratio 

The trait values for both depth and maximum width of the root in the 

segmented image. The ratio of maximum width to depth of the image 

is noted as width-to-depth ratio. 
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Convex area and 

solidity 

The convex hull of a geometric shape is a minimal sized convex 

polygon that can contain the shape. The ratio of network area and the 

convex area is noted as the solidity. 

Lower root area The lower root area is the area of the segmented image pixels that are 

located below the location of the medial axis pixel that has the 

maximum radius. 

Holes and Average hole 

size 

Holes are the disconnected background components and indicative of 

root branching and complexity. They can be counted by inverting the 

segmented image. The average hole size (area) is also calculated. 

Average Root 

Orientation 

For every medial axis pixel, the orientation at the pixel is computed by 

determining the mean orientation of medial axis pixels in a 40x40 pixel 

locality. The average of all these orientations is noted as average root 

orientation. 

Shallow Angle Freq., 

Medium Angle Freq., 

Steep Angle Freq. 

Given the skeletal image, for every pixel in the medial axis, we get the 

locations of the medial axis pixels in a 40x40 pixel locality and 

determine the orientation of these pixels in the locality. This orientation 

is noted for every medial axis pixel. Given these orientations, we 

calculate the frequency in bins less than 30, less than 60, and less than 

90 degrees. 

Computation time The time taken to extract traits for every plant root image. 
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Feature validation using a novel ground truth copper wire dataset 
 

 

RhizoVision Explorer (RVE) has been extensively validated, with one example using a novel physical, 

ground truth dataset that resembles roots. Copper wires of several diameters relevant to root studies 

were cut to specific lengths. Length was measured using string and diameter with a digital caliper. Volume 

and surface area were calculated for the physical data assuming the wires are cylinders. Regression 

analysis was performed using the lm() function in R for the RVE estimates versus the ground truth data 

for A) length, B) average diameter, C) surface area, and D) volume. Estimates from RhizoVision Explorer 

match extremely closely. Points are the raw data, blue line is the regression line, grey dashed line is the 

1:1 line, and the regression equations and coefficient of determination are given. Further validations and 

explanations are presented in a manuscript currently available as a preprint.  
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Included example images and settings files 

The RhizoVision Explorer directory structure includes a folder named imageexamples with images that 

serve as inspiration for the quality of high contrast images needed. The crowns folder includes excavated 

wheat root crown images for the Whole root mode, and the scans folder includes washed out wheat roots 

for the Broken roots mode. Settings files (CSV format) are included for each, and can be loaded as 

described above for correct output. Batch analysis can also be tested using these folders since there are 

multiple images of each type. 

The root crown images were acquired using the RhizoVision Crown platform that uses a backlight. 

 

The root scans were acquired using an Epson Perfection 12000 XL scanner with a transparency unit. 

 

 

 

While high-contrast color images are technically supported, thresholding in free software like GIMP or 

ImageJ is highly recommended. For more complex images, new machine learning methods like 

RootPainter may be helpful for prior segmentation, with the output images passed to RhizoVision 

Explorer. Still, acquiring clear, high contrast images is arguably the most important step for root 

phenotyping, so considerable effort should be made to get the right images before imaging the samples 

from an entire experiment. Conveniently, imaging methods can be tested by passing the images through 

RhizoVision Explorer at the start of an experiment, and refining the methods to optimize output. 

 


